macbook下eclipse 3.6闪退的问题

在macbook下使用eclipse cocoa 3.6(eclipse-php-oxygen-3-macosx-cocoa-x86_64.dmg)做php开发,在使用cut剪切时总是发生闪退的问题。
看了网上的别人的解决方案无果,于是只好采用通用解决方案——把eclipse升级到最新版本。于是下载了eclipse-php-2018-09-macosx-cocoa-x86_64.dmg
打开安装,解决发现无法打开启动安装程序。提示:eclipse无法启动报“Failed to find a Main Class in /Library/eclipse/pluginsplugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar”

这又是什么问题呢?才想可能是java版本兼容性问题。于是升级到最新的jdk。到https://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html下载最新的jdk 1.8
/Library/Java/JavaVirtualMachines/下面有默认的jdk 1.6,不用删除,设置一下.bash_profile即可:
JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.8.0_191.jdk/Contents/Home

启动eclipse安装程序,一切正常。

作者: 汤汤

2002年-2005年:在阿里巴巴,负责社区、搜索引擎开发,第一代SEO圈圈主;2006年-2018年:在19楼,负责技术、数据分析、市场推广、产品规划;

发表评论

电子邮件地址不会被公开。 必填项已用*标注